Напишите программу в двухмерном массиве 6*3 для каждой нечетной строки определить произведение положительных элементов

den4uk1402 den4uk1402    2   19.08.2019 13:00    0

Ответы
пупсикг пупсикг  05.10.2020 05:05
Var
arr:array[1..6,1..3] of integer;
i,j:integer;
p:longint;
begin
randomize;
p:=1;
for i:=1 to 6 do
begin
for j:=1 to 3 do
begin
arr[i,j]:=random(10);
write(arr[i,j]:5);
end;
writeln;
end;
for i:=1 to 6 do
begin
if i mod 2<>0 then
begin
for j:=1 to 3 do
if arr[i,j]>0 then p:=p*arr[i,j];
end;

end;
writeln('Произведение положительных элементов нечетных строк: ', p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика