Напишите программу в , C++, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6.Программа должна быть рабочей

даша3464 даша3464    2   07.06.2020 02:24    21

Ответы
MRA16 MRA16  15.10.2020 13:18

#include <iostream>

using namespace std;

int main() {

int n = 0;

setlocale (LC_ALL, "Russian");

cout << "Введите количество чисел: ";

cin >> n;

int sum(0);

int a[n];

for(int i = 0; i < n; ++i) {

 abc:

 cout << "№" << i << ": ";

 cin >> a[i];

 if(a[i]>300||a[i]%6!=0) {

  cout << "Число превышает 300 или не кратно 6. Повторите ввод" << endl;

  goto abc;

 }

 if(0 == a[i]%6) {

  sum += a[i];

 }

}

cout << "Сумма введённых чисел, кратных 6: " << sum;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика