Напишите программу в c++! дано предложение. вывести на экран слова, начинающиеся и оканчивающиеся на одну и ту же букву.

mrfotuna14 mrfotuna14    1   19.08.2019 01:20    11

Ответы
cvetok31maia cvetok31maia  31.08.2020 17:54
#include <iostream>
#include <string>

using namespace std;

#define IN 1 //внутри слова
#define OUT 0 //вне слова

int main()
{
    string s;
    getline(cin, s);
    int state = OUT; //позиция
    s = ' ' + s + ' ';
    int k = 0; //позиция начала слова
    for (int i = 0; i < s.size(); i++)
        if (s[i] == ' ') {
            if (state == IN && s[k] == s[i - 1])
                cout << s.substr(k, i - k + 1) << endl;
            state = OUT;
        } else if (state == OUT) {
            k = i;
            state = IN;
        }
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика