Напишите программу угадывания пароля с использованием цикла WHILE
(повторять ввод пароля пользователем, пока он не совпадёт с тем, который "зашифрован в программе")

elensarkisian elensarkisian    2   04.05.2020 11:55    2

Ответы
sweta2012 sweta2012  14.10.2020 06:40

var

pin : integer;

readPin : integer;

 

begin

 pin := 1234; //здесь напишешь  свой пин

  writeln('Write Pin :');

 readln(readPin);

 while readPin <> pin do begin

   writeln('Error wrong pin!');

   readln(readPin);

 end;

end.

Объяснение:

Вот

ПОКАЗАТЬ ОТВЕТЫ
v3tpr33 v3tpr33  14.10.2020 06:40

import random

code = ["954321"]

mineC = []

final = ""

i = 0

while True:

   while i < 6:

       wordC = random.randint(0, 9)

       mineC.append(wordC)

       i += 1

   if mineC != code:

       print(mineC)

       mineC.clear()

   if mineC == code:

       for i in mineC:

           final += i

       break

Работает только с паролями с цифрами

иначе придется выстраивать буквы по індексу и вызывать их так

   

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика