Напишите программу, удаляющую из слова i-ю букву. в алгоритмическом языке и блок схему.

sakinaxalilova2 sakinaxalilova2    3   29.06.2019 19:50    1

Ответы
itsnastyad itsnastyad  23.07.2020 16:59
Вариант с процедурой Delete

var
  s:string;
  k:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  Delete(s,k,1);
  Writeln('Результат: ',s)
end.

Вариант с функцией Copy

var
  s:string;
  k,n:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  n:=Length(s);
  s:=Copy(s,1,k-1)+Copy(s,k+1,n-k);
  Writeln('Результат: ',s)
end.

Вариант с циклами

var
  s,s1:string;
  k,i,n:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  n:=Length(s);
  s1:='';
  for i:=1 to k-1 do s1:=s1+s[i];
  for i:=k+1 to n do s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовое решение (одинаково для всех вариантов):
Введите слово: Таракан
Какую по порядку букву удалить? 4
Результат: Таркан

Блок-схемы всех вариантов находятся во вложениях
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика