tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу удаляющая
Напишите программу удаляющая из текста все буквы с его последней буквой
СуперТрололо
1 25.05.2019 20:10
2
Ответы
pankivk
01.10.2020 11:40
Uses crt;
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.
Эта программа рассчитана на то, что удаляется и последний символ тоже
ПОКАЗАТЬ ОТВЕТЫ
Анна5363646
01.10.2020 11:40
Var s:string; i:integer;
begin
read(s);
i:=1;
while i<length(s) do
if s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ladygagav
19.04.2021 13:01
Информатика база данных задание...
reginam800eymailru
19.09.2019 09:10
Решите программу на pascal abc...
NoRMTaKK
19.09.2019 10:10
Дано целое число. возвести его в квадрат, если оно неотрицательно и в четвертую степень, если отрицательно. разработать блок-схему для решения этой...
Pandivan
24.10.2021 11:41
Дано куб ABCDA1B1C1D1 знайти кут між відрізками A1C1 i BD...
stalker1897ox9hzs
24.10.2021 11:40
Обчисліть рівняння.x+9 3/4=12 1/2...
lanchik03
24.10.2021 11:40
Рассчитать величину экономии или перерасхода материала и коэффициент его использования, если норма расхода на единицу продукции составляет 1,04 кг. Выпуск продукции – 1 200...
ДашаЛис56
24.10.2021 11:40
Посчитай Сколько байт информации содержат 10 КБ...
muskuss12Ирада
24.10.2021 11:40
Водород имеет три изотопа . Укажите число нейтронов в ядре изотопов в порядке возрастания их относительной массы...
FruitAPps
24.10.2021 11:40
Доберіть синоніми й антоніми до виділеного слова цю сорочку мені вишивала материнська ласкава рука...
serejafox23
24.10.2021 11:40
Один і той самий вид гриба може жити й розмножуватися і як сапротроф, і як симбіонт відноситься до групи: а. справжні грибиБ.ліхенізовані грибиВ. несправжні грибиГ. слизовики...
Популярные вопросы
Напишите схемы процессов в результате которых образуется бромид калия...
2
Goщ жопа попа мощь да у менья больще вас жопа ха попа жопа мощь хатите...
2
. Решите уравнения: 6х-18=0,8(5х-10)...
1
. Дана функция: f(x)=-х2- х+12; а) Найдите значения функции f(3), f(-5)Известно,...
1
3. Определите признаки абсолютно и сословно-представительной монархииабсолютная...
1
Творча робота: написати твір-мініатору (6 речень) Останній подих зимми...
1
2. Laura is busy at the moment. She her studentshomework. is checkingcheckedare...
3
Написать код программы определяющую количество секунд по заданному количеству...
2
Задания 3. Правовая ситуацияУчащиеся 11 класса отмечали день рождения...
2
1. Вес в квадратном волосе 78 кг. Длина каждого волоса 1,95 м, длина S....
1
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.
Эта программа рассчитана на то, что удаляется и последний символ тоже
begin
read(s);
i:=1;
while i<length(s) do
if s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.