Напишите программу со алгоритмами запрашивающую количество элементов линейного массива действительных чисел не более 50 затем сам массив затем выводящую на экран полученный массив и на следующей строке номер последнего из его отрицательных элементов

эля792 эля792    2   20.07.2019 12:40    9

Ответы
Polina011020040 Polina011020040  03.10.2020 08:50
Ну, значит, как-то так:

program arrays;
type
myArr = array of integer;
var
arr : myArr;
neg : integer;
i, n : integer;

begin
write('Введите размер массива: ');
readln(n);
if n>50 then n:=50;
setLength(arr, n);
randomize;
neg :=0;
for i:=0 to n-1 do begin
arr[i]:=random(200)-100;
if arr[i]<0 then neg:=arr[i];
write(arr[i], ' ');
end;
writeln;
writeln ('Последний отрицательный элемент массива: ', neg);

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика