Напишите программу с клавиатуры вводится n целых чисел, nтоже вводится с клавиатуры. найти сумму нечетных, оканчивающихся на 7 или сообщить, что таких чисел в введенной последовательности нет

Tvoyainta Tvoyainta    3   28.08.2019 05:20    7

Ответы
suiunbailkyzy99 suiunbailkyzy99  06.10.2020 00:02
Var n,i,a,s,f:integer;
begin
write('n = ');
readln(n);
s:=0; f:=0;
for i:=1 to n do
 begin
 readln(a);
 if abs(a) mod 10 = 7
  then begin s:=s+a; f:=1; end;
 end;
if f=1
 then writeln('Сумма нечетных чисел, оканчивающихся на 7 = ',s)
 else writeln('среди введенных чисел нет нечетных, оканчивающихся на 7');
end.

Пример:
n = 5
25
-17
71
68
27
Сумма нечетных чисел, оканчивающихся на 7 = 10
ПОКАЗАТЬ ОТВЕТЫ
katgri83 katgri83  06.10.2020 00:02
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger(ReadInteger).Where(m->abs(m) mod 10=7).ToArray;
  if a.Length=0 then Writeln('Нет чисел, оканчивающихся на 7')
  else Writeln('Сумма чисел, оканчивающихся на 7: ',a.Sum)
end.

Пример
5
16 37 3 7 -27
Сумма чисел, оканчивающихся на 7: 17
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика