Напишите программу, после первого четного элемента вставить 0. пример: из массива a[5]: 1 6 8 3 4 должен получиться массив a[6]: 1 6 0 8 3 4.

Михайлов11 Михайлов11    2   26.06.2019 07:00    6

Ответы
Dan20147 Dan20147  21.07.2020 07:28
Const     
n = 10; 
var   
a : array [1..n] of integer; 
r : boolean;   
i,j : integer;
 begin 
//Формирование массива пропущено   
 
r := true;      
While r do   
begin   
 if a[i] mod 2 =0 then     
begin     
 for j := n-1 downto i + 2 do       
 a[j] := a[j-1];       
a[i+1] := 0;       
r := false;     
end;     
i := i +1;   
end;  
for i := 1 to n do 
writeln (a[i]);   
end.

Во избежании ошибок стоит учесть наличие такового элемента в массиве и размерность массива (чтобы его можно было корректно расширить на один элемент)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика