Напишите программу: посчитать количество четных цифр в числе, введенном с клавиатуры. pascal

KroJlick20178 KroJlick20178    3   22.09.2019 01:00    7

Ответы
jfjjthvhhcj jfjjthvhhcj  08.10.2020 08:21
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (n,k):=(Abs(ReadInteger('n=')),0);
  if n=0 then k:=1
  else
    while n>0 do begin
      if (n mod 10).IsEven then k+=1;
      n:=n div 10
      end;
  Writeln('Четных цифр: ',k)
end.

Пример
n= -623451
Четных цифр: 3
ПОКАЗАТЬ ОТВЕТЫ
Ьала Ьала  08.10.2020 08:21
Var
a, b, k : integer;
begin
k := 0;
write('введите число: ');
readln(a);
while a <> 0 do
begin
b := a mod 10;
if b mod 2 = 0 then inc(k);
a := a div 10
Writeln ('Чётных: ', a);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика