Напишите программу: подсчитать количество нулей в массиве, состоящем из n целых чисел. элементы массива задавать вручную.

tasyakondrateva0 tasyakondrateva0    2   17.12.2019 14:07    2

Ответы
Loikov1 Loikov1  11.08.2020 21:54

1. Динамический массив

program p_1;

var n,i,k:integer;

a:array of integer;

begin

write('Введите количество элементов массива ');

readln (n);

a := new integer[n+1];

for i:=1 to n do

begin

write('Введите ',i,' элемент массива ');

readln (a[i])

end;

k:=0;

for i:=1 to n do

if a[i] = 0 then k:=k+1;

writeln;

writeln('k = ',k)

end.

2. Статический массив

program p_1;

var n,i,k:integer;

a:array [1..1000] of integer;

begin

write('Введите количество элементов массива ');

readln (n);

for i:=1 to n do

begin

write('Введите ',i,' элемент массива ');

readln (a[i])

end;

k:=0;

for i:=1 to n do

if a[i] = 0 then k:=k+1;

writeln;

writeln('k = ',k)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика