Напишите программу по паскалю. дано трехзначное натуральное число a. требуется определить, какая из его цифр большая. исходные данные: 835. результат: 8.

hren4 hren4    2   25.07.2019 08:10    1

Ответы
aspier2016 aspier2016  24.09.2020 11:38
Var a,c,k,max,chislo: integer;
begin
readln(chislo);
max:=-10;
c:=1;
repeat
a:=chislo div 10
c:=c+1;
until a=0;
k:=10;
for i to c do begin
if (chislo mod k)> max then max:=(chislo mod k)
chislo:=chislo mod k;
end;
writeln ( max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика