Напишите программу. Паскаль.
Вывести квадрат 5х5 из чисел от 1 до 25 “змейкой”. В первой строке
от 1 до 5, во второй от 10 до 6, в третьей 11 до 15 и т.д.

Настя123123ноно Настя123123ноно    3   19.11.2020 15:51    1

Ответы
loymik loymik  12.02.2021 18:09

const

 n = 5;

var

 a: array[1..n, 1..n] of integer;

 k, c, i, j: integer;

begin  

 c := 1;

 k := 1;

 while c <= n do  

 begin

   for i := 1 to n do  

     begin  

       a[c, i] := k;

       k := k + 1;  

     end;  

   c := c + 1;

   if c>n then break;

   for i := n downto 1 do  

     begin  

       a[c, i] := k;

       k := k + 1;  

     end;  

   c := c + 1;

 end;

 for i := 1 to n do  

   begin

     for j := 1 to n do  

       write(a[i, j]:3);

     writeLn;

   end;  

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика