Напишите программу паскаль. вроде циклы дано натуральное число n. определить, является ли оно совершенным. совершенное число n равно сумме его делителей, не превосходящих само n.

alechka7 alechka7    3   28.05.2019 05:40    4

Ответы
Julia28122002 Julia28122002  25.06.2020 15:53
Program gt;
var n,s,l,i:longint;
begin
read(n);
s:=0;
l:=round(sqrt(n));
for i:=1 to l do
begin
if(n mod i=0)then begin
s:=s+i;
s:=s+n div i;
end;
end;
if(l*l=n)then s:=s-l;
if(s<=n)then writeln('ДА ЭТО ПРАВДА')else writeln('НЕТ');
end.
2)
program gt;
var n:integer;
begin
read(n);
if(n=1)then writeln('ДА')else writeln('НЕТ');
end.
3)
program gt;
var n,s:integer;
begin
read(n);
s:=((1+n)*n)div 2;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика