tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу паскаль:
Напишите программу паскаль: с клавиатуры вводится число от 0 до 1000 включительно. каждая цифра не превосходит 6. найти сумму промежуточных значений между наибольшей и наименьшей цифрами в числе?
mansya01
3 02.09.2019 03:30
3
Ответы
крыстя1
16.08.2020 08:01
Попробуй, может сработает)
program num32;var
nums, i, min, max, a, i2, i3, sum: integer;begin
min := 7;
max := 0;
sum := 0;
readln(nums);
while nums <> 0 do
begin
if (((nums mod 10) > max)) then begin
max := nums mod 10;
end;
if (((nums mod 10) < min)) then begin
min := nums mod 10;
end;
nums := nums div 10;
end;
if (min > max) then begin
for i2 := max to min do
sum := sum + i2;
end;
if (max > min) then begin
for i2 := min to max do
sum := sum + i2;
end;
writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
shvey
23.05.2019 18:20
Решите по ! 3.алфавит некоторого языка состоит из 4 символов.оцените в байтах информационный объем сообщения длиной в 16 символов....
максир
23.05.2019 18:20
Вкодировке кои-8 каждый символ кодируется одним байтом. определите кол-во символов в сообщении, если информационный объем сообщения в этой кодировке равен 160 бит....
Zhenechka12332145
12.05.2019 22:09
Написать (pascal) 1.вводится кол-во чисел n,затем сами числа,вычислить среднее арифметическое всех чисел,которые делятся на 5 2.вводятся 2 числа a и b,вывести квадраты...
121517
22.05.2020 06:28
Який з циклів не виконається жодного разу? * For А := 1 То 10 Do S = S + А; For А := 5 То 7 Do S = S + А; For А := 2 То 5 Do S = S + А; For А := 10 То 0 Do S = S...
zaj2015
22.05.2020 06:28
Отметьте условия хаписанные на языке python правильно 1)а _ 02) х =33)х 0 or y 04)c=/05)a=!b6)-5 a 107)x 0 y 08)a 10 и b 59)x == 610)x =y = z11)x 0ответьте ...
Elina1987
22.05.2020 05:58
Всем привет С полным решением нужно))...
бббб9
24.04.2020 10:26
Это очень Определите значения переменной Z после выполнения фрагмента программы: a:=2; x:=a+2; if x 4 then x:=x+2*a else x:=a-x 2. Составить условие,которое является...
kira260606
24.04.2020 10:26
1) некоторое сообщение зашифровали по методу Вегенера с ключом ИКТ , после чего полученную зашифрованную фразу повторно зашифровали перестановкой с ключом ЗАЧЁТ...
Rentels
24.04.2020 10:25
Напишите наибольшее целое число х для которого истинно высказывание не (х нечетное) и не (х =6)...
ArT003
24.04.2020 10:25
Какой код необходимо установить на адресных входах и входе ЕО, чтобы при частоте входного сигнала Fт = 32 кГц, получить на выходе схемы частоту 500 Гц?А0 – 1; А2...
Популярные вопросы
Составить словосочетания со словами: ателье ,кашне , модель ,...
3
Миша в бутылку положил кусочки льда и закрутил крышку стенки...
3
Текст к пословице я від теплого слова і лід розмерзає...
1
Склади речення с поданих слів, використовуючи по одному слову...
3
Почему амеба встречаестя в водоемах,где много органических веществ...
2
Запиши четыре группы родственных слов обозначь суффиксы -ик -ек...
3
Із 48 кг свіжих помідорів одержують 16 кг томату. скільки томату...
2
Найдите координаты точек плоскости, в кторых кубическая парабола...
3
Решить укажите в какой группе находится слова с двумя приставками...
2
Допиши предложение у существительных 1-ог склонения падеже окончание...
1
program num32;var
nums, i, min, max, a, i2, i3, sum: integer;begin
min := 7;
max := 0;
sum := 0;
readln(nums);
while nums <> 0 do
begin
if (((nums mod 10) > max)) then begin
max := nums mod 10;
end;
if (((nums mod 10) < min)) then begin
min := nums mod 10;
end;
nums := nums div 10;
end;
if (min > max) then begin
for i2 := max to min do
sum := sum + i2;
end;
if (max > min) then begin
for i2 := min to max do
sum := sum + i2;
end;
writeln(sum);
end.