Напишите программу (паскаль) для вычисления разности s=1 - 1*2 - 1*2*5 - 1*2*5*8 - 1*2*5*8*11

IGUMANITARII IGUMANITARII    3   29.08.2019 18:50    3

Ответы
Nirronua Nirronua  06.10.2020 03:29
Первый вариант:

Var
   A,N:longint;
   S,P:real;
Begin
Write('Введите количество членов последовательности(не менее одного): ');
ReadLn(N);
S:=1;
P:=1;
For N:= 0 to N-1 do
    Begin
    P:=P*(2+N*3);
    S:=S-P
    End;
WriteLn('S = ',S);
End.

Второй вариант:

Var
   A,N:longint;
   S,P:real;
Begin
S:=1;
P:=1;
For N:= 0 to 3 do
    Begin
    P:=P*(2+N*3);
    S:=S-P
    End;
WriteLn('S = ',S);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика