tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу(pascal)
Напишите программу(pascal) найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.
Ликааааааааап
3 23.08.2019 08:10
1
Ответы
Dgj8
20.08.2020 14:12
Program n1;
var sum,a,c: integer;
begin
readln(a);
sum:=0;
while true do
begin
readln(c);
if c=0 then break;
if c mod a=0 then sum:=sum+c;
end;
writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Vikohkamy
20.08.2020 14:12
Предполагается, что ввод завершает число 0
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadInteger('a=');
Writeln(ReadSeqIntegerWhile(x->x<>0).Where(x->x mod a=0).Sum)
end.
Пример
a= 2
5 7 12 8 -4 3 11 0
16
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kivialisalittlee
27.10.2020 10:56
Постройте таблицу истинности для выражения F=¬A∧(AvB)...
ZlataPaw
27.10.2020 10:57
информационный объем одного символа некоторого сообщения равен 6 битам какова мощность использованного алфавита...
ostapsheremetaoooo
27.10.2020 10:57
Модель это - a)это предмет, явление, процесс окружающего мира, все, на что направлена деятельность человека.b)это построение и изучение моделей реально существующих объектов,...
JackDead
27.10.2020 11:03
Информатика, 9 класс. Требуются ответы на эти задания....
Rake4
13.05.2019 18:13
Соч по информатике 6 класс 4 четверть...
progonskaij
13.05.2019 18:10
Написать рисунок с лягушки. желательно начать слева....
Smash2302
04.10.2021 00:57
Можно , чертёж и объяснение...
polinaandreeva10
04.10.2021 00:57
наставить слова в порядке обратных словарей....
stone8r4
04.10.2021 01:03
Pentiym микропроцессор қайда пайда болды...
dianaandmasha
04.10.2021 01:04
Метеорологическая станция ведёт наблюдение за влажностью воздуха результатом 1 измерения является целое число от 0 до 100% которое записывается при минимально возможного количества...
Популярные вопросы
Периметр прямоугольника равен 28см, а площадь 48см(в квадрате) найдите длину...
2
Площадь поверхности октаэдра 32корень3см^ наидите рёбра октаэдра...
1
Зачеркните лишнее слово, присутствующее в каждой строке. 1) щука, карась....
1
Проанализируйте слова.обозначьте состав слов и укажите их образования...
3
Разложите на множители: а)(a+3b)^2-(3a-b)^2 б)a-b^2-b+a^2 ^- это сепень...
3
Разберите предложение по членам предложениям : буратино буратино понял ,...
2
Хозяйка купила 2 пакетика семян: один – с семенами тыквы, а второй – с семенами...
2
Укажите номер чётной функции: 1) ; 2) ; 3) ; 4) ; 5)...
3
Зробіть синтаксичний розбір речення: рука трудящих пануватиме,а лінива рука...
1
Можно ли считать предпринимательством перепродажу вещей (товаров)...
1
var sum,a,c: integer;
begin
readln(a);
sum:=0;
while true do
begin
readln(c);
if c=0 then break;
if c mod a=0 then sum:=sum+c;
end;
writeln(sum);
end.
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadInteger('a=');
Writeln(ReadSeqIntegerWhile(x->x<>0).Where(x->x mod a=0).Sum)
end.
Пример
a= 2
5 7 12 8 -4 3 11 0
16