Напишите программу, определяющую, является ли введенная строка палиндромом

(т. е. читается одинаково слева-направо и справа-налево).

а) с учетом пробелов (например, таким палиндромом будет строка «дом мод»);
На python​

abeldinova85 abeldinova85    2   02.05.2020 10:52    3

Ответы
280605 280605  14.10.2020 05:57

string = input()

palindrome = True

for i in range(1, len(string) // 2):

   if string[i - 1] != string[-i]:

       palindrome = False

print('Да' if palindrome else 'Нет')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика