Напишите программу, определяющую по координатам точки, в какой четверти системы координат она находится.​

mrmersbrady mrmersbrady    1   17.03.2020 09:42    2

Ответы
Hhh2341 Hhh2341  11.10.2020 23:50

Объяснение: Для решения задачи нам понадобиться оператор if. В самой задаче мы будем использовать всего две переменные , которые у нас будут хранить координаты.

1

2

3

4

5

uses crt ;

var

x, y : integer ;

begin

end.

Мы объявили две переменные. Теперь попросим пользователя ввести значения этих переменных :

1

2

write('Введите x : '); readln(x);

write('Введите y : '); readln(y);

И после того как у нас в переменных есть какие то числа , мы пишем условие :

1

2

3

4

5

6

7

8

9

10

11

12

13

14

write ('Номер четверти координатной плоскости: ');

if (x > 0) and (y > 0) then

writeln ('I')

else

if (x < 0) and (y > 0) then

writeln ('II')

else

if (x < 0) and (y < 0) then

writeln ('III')

else

if (x > 0) and (y < 0) then

writeln ('IV')

else

writeln ('-. Точка лежит на оси.');

Тут уже идет больше знание математики , ну и конечно же умение писать вложенные условия .

Весь код программы :

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

uses crt ;

var

x, y : integer ;

begin

clrscr; {очищаем экран}

write('Введите x : '); readln(x);

write('Введите y : '); readln(y);

write ('Номер четверти координатной плоскости: ');

if (x > 0) and (y > 0) then

writeln ('I')

else

if (x < 0) and (y > 0) then

writeln ('II')

else

if (x < 0) and (y < 0) then

writeln ('III')

else

if (x > 0) and (y < 0) then

writeln ('IV')

else

writeln ('-. Точка лежит на оси.');

readln; {чтобы программа не закрывалась}

end.

Вот результат :

ris11

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика