Напишите программу, определяющую число слов в строке. одно слово от другого отделяется 1 пробелом c#

v777or777 v777or777    1   24.06.2019 15:34    4

Ответы
Polyak56 Polyak56  02.10.2020 10:24

ну вроде бы так, если все верно, то отметь как лучший ответ, буду благодарна

есть несколько программ, и все они должны подойти, смотри картинки

k:=1;

for i:=1 to length(s) do

if s[i]=' ' then k:=k+1;

Количество слов на 1 больше чем пробелов.

var

s:string;

i,r:integer;

begin

readln(s); //ввод строки

i:=1;

while i<=length(s) do begin

if s[i]=' ' then r:=r+1;

i:=i+1;

end;

writeln(r+1);

readln;

end.


Напишите программу, определяющую число слов в строке. одно слово от другого отделяется 1 пробелом c#
Напишите программу, определяющую число слов в строке. одно слово от другого отделяется 1 пробелом c#
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика