tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу, обнуляющие
Напишите программу, обнуляющие все биты числа, кроме нескольких последних
dasha5132
1 27.06.2019 03:40
5
Ответы
eataev
02.10.2020 12:43
N - число не обнуляемых битов, Х - обрабатываемое число. C++.
int k = 0;
for(size_t i = 0; i < N; i++) k = (k << 1) | 1;
Х = Х & k;
Х - результат
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ангелок76
10.08.2019 10:10
Графическая форма представления информации(множеественное число) 5 букв (первая с последняя ы...
DanilBeast
10.08.2019 10:10
Составьте программу которая выводит частное от деления nнатуральных чисел на 2...
PROKUROR111
20.09.2019 01:10
Составьте алгоритм возведения чётного числа в квадрат,а нечётного-в куб....
saha12389085
20.09.2019 01:10
Обсудите , можно ли сохранить фотографию в векторном формате от чего зависит размер файла, в котором хранится векторный рисунок? почему векторные рисунки не искажаются при изменении...
Mariaa77
09.04.2020 11:27
с заданием по информатике1. Ситуация. Вы отправили в магазин деда-инженера. Он вместо батона, купил топор. Подумайте, почему так произошло и что мы не учли при постановке задачи...
KALINACHKA
09.04.2020 11:26
Даны массивы, выберите чему равны следующие номера и элементы массива (ответы запишите): a [120, 125, 16,-4, 10, 18, 22, 316] b [красный, желтый, голубой, зеленый, оранжевый,...
Reson1
18.03.2021 15:21
Какой правильный ответ и почему? Объясните кратко, если не сложно Определите значение переменной A после выполнения фрагмента программы: Если a=8, b=3Варианты ответовА) 64В)27С)91D)11...
ctalin123123
18.03.2021 15:22
Заполните массив размером из N элементов квадратами индексов массива....
aleksinia
17.05.2019 23:49
Переведите в c++. var n,k,n2: int64; beginread(n); k: =0; n2: =1; while n2 =n do begin n2: =n2*2; k: =k+1; end; write(k); end....
sumochkaaaaa
18.05.2019 01:50
=ввести три целых числа с клавиатуры. найти их произведение, сумму и среднее арифметическое....
Популярные вопросы
Вы живёте (допустим) на 10 этаже...
3
Выполнить задания с 1 по 10Сочно...
2
В чём заключается хитрость левши...
1
АЛКАНЫ, ) Октан содержит 8 атомов углерода и относится к гомологическому...
3
Мне 10 лет я в седьмом классе что делать...
2
В таблице 3 приведена зависимость объема прямоугольного параллелепипеда (V,...
2
Прочитайте рассказР.Погодина «Время говорит – пора». 2.ответьте на во письменно....
3
Почему нельзя пользоваться электричеством, открытым огнём и газом в повреждённом...
1
- Изменилась ли Снегурочка в финале? Какой она стала? (действие 4 явление...
3
Закончить уравнения возможных реакций.1. Na+ O2→2. Li+ H2O→3. Mg+ HNO3(разб)→...
3
int k = 0;
for(size_t i = 0; i < N; i++) k = (k << 1) | 1;
Х = Х & k;
Х - результат