Напишите программу нахождения площади и высоты равностороннего треугольника, если известна его сторона на языке паскаль. заранее

mark086 mark086    2   08.07.2019 15:50    3

Ответы
Jdhcb Jdhcb  02.10.2020 22:53
Найдем площадь равностороннего треугольника по формуле:
S = \frac{1}{2} ah, где h = \sqrt{a^{2} - \frac{a^{2}}{4} } = \frac{ \sqrt{3} }{2} a
S = \frac{ \sqrt{3} }{4} a^{2}
Составим программу:
var a, h, s: real;
begin
  read(a);
  h := sqrt(3) / 2 * a;
  s := 1 / 2 * a * h;
  writeln('h = ', h : 0 : 1);
  writeln('S = ', s : 0 : 1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика