Напишите программу, находящую сумму нечетных цифр числа x в питоне

Марямчик Марямчик    2   04.10.2019 06:50    0

Ответы
рф777 рф777  09.10.2020 19:02

x = int (input()) #ввод х, х - целое число

s = 0 #переменная для суммы

if x == 0:

   print(s) #если х - нулевой, то сумма нечетных цифр равна 0

else:

   while x != 0:  #начинаем цикл поиска цифр

       c = x%10 # "отрезаем" от х последнюю цифру и записываем в переменную с

       if c != 0 and c%2 != 0:  #если цифра с делится на 2 с остатком, то она нечетная

           s = s + c #тогда мы ее прибавляем к s

       x = x // 10 #"отрезаем" от х последнюю цифру, а оставшееся число записываем в х

   print(s)

           

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика