Напишите программу, находящую сумму арифметической прогрессии по заданным значениям первого элемента, разности и количества элементов последовательности.

cvetaharlanova cvetaharlanova    2   12.08.2019 01:50    1

Ответы
milkyyyw milkyyyw  04.10.2020 12:26
1. Вспомним формулу для нахождения суммы арифметической прогрессии:

S_{n} = \frac{2a_{1}+(n-1)*d}{2} * n

Где а - это первый элемент последовательности
n - количество элементов
d -разность.

Составим программу на языке СИ

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int a,n,d;
double y;
int main(void)
{
printf("a=");
scanf("%d", &a);
printf("n=");
scanf("%d", &n);
printf("d=");
scanf("%d", &d);
y=((2*a+(n-1)*d)/2.0)*n;
printf("%lf", y);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика