tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу находящую
Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел)
SalaevaDarina
1 27.05.2019 03:50
5
Ответы
наталя09
23.06.2020 20:27
Var
a, b, c, d: integer;
function max(i1, i2: integer): integer;
begin
if i1 > i2 then max := i1 else max := i2;
end;
begin
read(a, b, c, d);
writeln(max(max(max(a, b), c), d));
end.
не помню как процедуры писать, но с функциями даже удобнее
ПОКАЗАТЬ ОТВЕТЫ
yanastepina83
23.06.2020 20:27
Program ufhg;
uses crt;
var a,b,c,d, m: integer;
begin
readln(a,b,c,d);
m:=a;
if(b>m) then m:=b;
if(c>m) then m:=c;
if(d>m) then m:=d;
writeln(m);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
gybshova
29.06.2019 10:40
Если список инициализации короче, чем длина объявленного массива, то: 1)массив укорачивается, согласно списку инициализации 2)правильных утверждений нет 3)значения оставшихся...
LizaS0404
29.06.2019 10:40
1) вычислить время звучания моноаудиозаписи, если: частота дискретизации равна 11 кгц; глубина кодирования равна 8 битов; объем файла равен 1375 кбайт 2) вычислить глубину...
anastasiya11лет
17.07.2019 10:10
Дана строка. найдите в этой строке самое длинное слово и выведите его. если в строке несколько слов одинаковой максимальной длины, выведите первое из них. python или с++.заранее...
nastya291204061012
17.07.2019 10:10
Через некоторое соединение со скоростью 5120 бит в секунду в течение 24 секунд передаётся файл. определите скорость соединения (в битах в секунду), через которое этот же...
lll38
12.09.2019 08:50
Информатика 9 класс какие услуги (сервисы) образовательного характера могут предоставлять информационные ресурсы?...
Nina2111
12.09.2019 08:50
Проверьте, , программу. вот : составьте программу, выводящую на экран все двухзначные числа, у которых первая цифра в два раза больше второй. только честно, . это важно)...
RomanovDanya201DAnua
12.09.2019 08:50
1. алгоритм перевода целых чисел из десятичной системы счисления в любую другую....
клим512
21.12.2020 20:39
Запишите алгоритм построения детали в тетрадь.На фотке тема!...
умничка267
21.12.2020 20:40
1 Задание. Рассмотрите рисунки. Определите вид графики по данным рисункам. Укажите преимущества и недостаткиграфических редактор, с которых созданы рисунки.I...
даша1820065к
27.04.2019 00:50
(25б ) решить нужно 1)объясните как решать подобные в системе счисления с основанием а запись числа 74 оканчивается на 4 и содержит 3 цифры. чему равно а? 2) компьютер...
Популярные вопросы
Что означает- грамоте учиться-вперед пригодиться...
1
Найдите все числа которые можно разложить на два двузначных простых...
2
Объяснение к уравнению х-18=42 и 34+а=60...
3
Сочинить рассказ-сочинение (небольшое) на тему чем для меня является...
1
1) маленький, малявка, маляр, малыш. 2) гроза, грозный, гроздь, грозовой....
3
Как заполнить пропуски в таблице 1-е слагаемое неизвестно 2-е слагаемое...
1
Она молча подала мне свою руку еще дрожавшую от волнения и испуга. расставьте...
3
Аня и коля решали .коля решил 26 ,а аня на 16 больше.сколько всего решили...
1
Составить из слов аппарат, образование, наездник, предложения....
3
Раздели на слоги и для переноса слова; ежи,иголки,камыши...
2
a, b, c, d: integer;
function max(i1, i2: integer): integer;
begin
if i1 > i2 then max := i1 else max := i2;
end;
begin
read(a, b, c, d);
writeln(max(max(max(a, b), c), d));
end.
не помню как процедуры писать, но с функциями даже удобнее
uses crt;
var a,b,c,d, m: integer;
begin
readln(a,b,c,d);
m:=a;
if(b>m) then m:=b;
if(c>m) then m:=c;
if(d>m) then m:=d;
writeln(m);
end.