Напишите программу на языке си. дан текст произвольной длины оканчивающийся точкой c запятой. подсчитать количество “: =” в тексте

makhero111 makhero111    2   03.09.2019 05:20    6

Ответы
alexey1009 alexey1009  06.10.2020 13:59
#include <stdio.h>

int main(void) {
char c1,c2;
int k=0;
printf("Вводите символы (в конце ';')\n");
scanf("%c",&c2);
do {
c1 = c2;
scanf("%c",&c2);
if ((c1 == ':')&&(c2 == '=')) k++;
}
while (c2 != ';');
printf("k = %d",k);
return 0;
}

Пример:
Вводите символы (в конце ';') 
i:=0, s:=0;
k = 2
ПОКАЗАТЬ ОТВЕТЫ
Артем14698752269 Артем14698752269  06.10.2020 13:59
:=;"
  int
    i = 1,
    cnt = 0;

  if (str[0] == ';')
    return;
  
  while (str[i] != ';')
  {
    if (str[i - 1] == ':' && str[i] == '=')      cnt++;    i++;  }

  printf("%i\n", cnt);
  _getch();
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика