tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу на
Напишите программу на языке программирования паскаль в результате выполнения которого получалась сумма всех элементов массива
vikasss1581
1 18.09.2019 19:30
4
Ответы
Ника11112222222x
08.10.2020 00:40
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('S=',a.Sum)
end.
Пример
n= 13
-33 4 19 46 -23 19 -32 31 -10 48 -13 -32 -10
S=14
ПОКАЗАТЬ ОТВЕТЫ
yuratihonov
08.10.2020 00:40
Var a: array [1..20] of integer; i: integer; sum: integer;begin
sum:=0; for i:=1 to 20 do begin a[i] := random(20); write(a[i],' '); sum:= sum+a[i]; end; writeln(); writeln('Сумма всех элементов : ',sum); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lonelyofiory
03.03.2021 09:15
написать программу которая заполняет массив, состоящий из 10 элементов случайными числами из промежутка [-20;20] и находит максимальный элемент кратный 5...
коршун4
25.12.2020 12:42
помагите я не использую компьютер напишите про этих копютерных програм нужно ...
Besmertnay123
25.12.2020 12:41
ответьте на следующие вопросы коротко и запишите ответы в тетрадь! 1. Что такое источник информации?2. Какими бывают информационные каналы?3. Что относится к источникам информации?4....
Роннилав
25.12.2020 12:39
Напишите программы в тетради, которые выводят на экран: «ответ: 15+16=31», «Скоро! 31 декабря будет праздник!», «18 16 98» (каждое высказывание тремя разными Например: write...
SAMAWHICE
25.12.2020 12:37
Сообщение о том, что из коробки достали один карандаш несет 6 бит информации. Сколько карандашей в коробке? 2 При угадывании целого числа в некотором диапазоне получено 9 бит...
Qucha
25.12.2020 12:37
Вычислить для произвольного n pascal...
ВанькаНер
25.12.2020 12:36
Назначение Excel … 1)проведение расчетов, решение оптимизационных задач, построение диаграмм, создание web-документов 2)проведение расчетов 3)проведение расчетов, решение оптимизационных...
turebekrasul
25.12.2020 12:36
Сколько измерений имеет объект в SketchUp и какие?...
89224717238
25.12.2020 12:35
Какие виды информационных моделей используют и текстовую и графическую информацию? а)Знаковыеб) Смешанныев)Графическиег Текстовые...
дадададад2
25.12.2020 12:35
Очень завтра уже будет поздно!...
Популярные вопросы
Choose the correct words. 1 Hello! We re new students and my/our/his names...
1
Задакале 1. Выполните тест ( ) 1. Самая древняя геологическая эра называется:а)...
1
147. Изучите внимательно схему. Расскажите по ней ознаках препинания в предложениях...
3
Металдардың белсенділік қатары...
3
Әр мекенге сын айтып,пікір білдіретін шығарма кейіпкерін көрсет. пшр...
2
Решите у меня СОР идёт, ВРЕМЯ Можно решение ещё. Как вы это решили, так...
2
Назови 3 последствия образования государственности у тюрков в VI веке...
1
СОР по истории Заполните сравнительную таблицу:Автономия АламВопросы для...
1
Ежелгі Лавразия құрамында болған материктер ?!? Скажите...
2
)В каком году был открыт первый профессиональный казахский театр в Кызыл-Орде?...
3
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('S=',a.Sum)
end.
Пример
n= 13
-33 4 19 46 -23 19 -32 31 -10 48 -13 -32 -10
S=14
sum:=0; for i:=1 to 20 do begin a[i] := random(20); write(a[i],' '); sum:= sum+a[i]; end; writeln(); writeln('Сумма всех элементов : ',sum); end.