Напишите программу на языке программирования (или составьте алгоритм). заполнить массив в, состоящий из сорока элементов, случайными целыми числами из интервала [–30; 50] и найти максимальный элемент.

Wonderfulgirl30 Wonderfulgirl30    1   28.07.2019 18:40    4

Ответы
soloviovav82owjd2t soloviovav82owjd2t  25.09.2020 22:15
 var i,max:integer;
      b:array[1..40] of integer;
begin
  randomize;
  for i:=1 to 40 do
     begin
      b[i]:=random(random(80))-30;
      write(b[i],' ');
    end;
    writeln;
    max:=b[1];
  for i:=1 to 40 do
     begin
      if b[i]>= max then
        begin
          max:=b[i];
         end;
    end;
  writeln('Максимальный элемент массива: ',max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика