Напишите программу на языке паскаль. требуется выяснить, является ли введенное пользователем число совершенным. совершенным называется такое число, сумма делителей которого равна этому числу, если не учитывать в ней последний делитель-само заданное число. например, число "6" является совершенным
числом, поскольку оно имеет три делителя: 1, 2, 3 и при этом 1+2+3=6, то есть самому числу

vika3v vika3v    3   08.10.2019 08:40    0

Ответы
Mariafetisova1 Mariafetisova1  10.10.2020 03:46

var N,i,k:integer;

BEGIN

readln(N);

k:=0;

for i:=1 to N div 2 do

if (N mod i=0) then

k:=k+i;

if (k=N) then

writeln('Да') else

writeln('Нет');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика