Напишите программу на языке паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный. если они прямоугольные, то должно выводится сообщение 'это прямоугольный треугольник'.

daviduk2509 daviduk2509    3   22.06.2019 17:30    1

Ответы
romafadeev1 romafadeev1  02.10.2020 08:40
Var a,b,c:real;
begin
read(a, b, c);
if ((a=sqrt(sqr(b)+sqr(c)))or(b=sqrt(sqr(a)+sqr(c)))or(c=sqrt(sqr(a)+sqr(bthen
write('Это прямоугольный треугольник')
else
write('Это не прямоугольный треугольник')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика