Напишите программу на языке паскаль. надо заменить меньшее из двух данных чисел на их среднее арифметическое а большее из них на среднее .

hihok hihok    2   30.08.2019 08:40    1

Ответы
ЮлічкаВдовіна ЮлічкаВдовіна  06.10.2020 04:47
Var
  a, b,sa,sg: real;

begin
  write('Введите a ');readln(a);
  write('Введите b ');readln(b);
  sa:=(a + b) / 2;
  sg:=sqrt(a * b);
  if a < b then begin
    a := sa;
    b := sg;
  end
  else begin
    a := sg;
    b := sa;
  end;
  writeln('a= ', a:0:2, ' ', 'b= ', b:0:2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы