Напишите программу на языке паскаль, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Заранее благодарен

whitezizickela whitezizickela    1   14.03.2021 06:18    8

Ответы
HLNLZ HLNLZ  13.04.2021 06:22

Program kratn_6_okanch_4;

var a,s: integer;

begin

wri teln('Введите натуральные числа, в конце введите 0');

readln(a);

s:= 0;

while a<>0 do

begin

if (a mod 6 = 0) and (a mod 10 = 4) then

s := s + a;

readln(a);

end;

writeln('Сумма всех чисел кратных 6 и оканчивающихся на 4=',s)

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика