Напишите программу на языке паскаль, которая будет вычислять наибольший общий делитель для двух целых чисел а) с repeat б) с while

yuliyaefremova3 yuliyaefremova3    1   16.04.2019 19:25    1

Ответы
KseniaEnrrgy KseniaEnrrgy  29.05.2020 16:59

а)

var a,b:integer;

begin

read(a,b);

repeat

if a>b then

a:=a-b

else

b:=b-a;

until (a=b);

write(a);

end.

б)

var a,b:integer;

begin

read(a,b);

while (a<>b) do

if a>b then

a:=a-b

else

b:=b-a;

write(a);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика