tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу на языке
Напишите программу на языке паскаль как найти корни квадратного уравнения ( ax+bx+c=0 ),при этом использовав if then else со значениями дискрименанта d=0 d< 0 b d> 0
leron9999
1 19.08.2019 02:50
4
Ответы
Hikolog
02.08.2020 19:32
Var
a, b, c, D: real;
x1, x2: real;
begin
Write('Введите А:'); Readln(a);
Write('Введите B:'); Readln(b);
Write('Введите C:'); Readln(c);
D := sqr(b) - (4 * a * c);
if (D > 0) then
begin
x1 := (-b + sqrt(D)) / (2 * a);
x2 := (-b - sqrt(D)) / (2 * a);
Writeln('x1=', x1);
Writeln('x2=', x2); end else
if(d = 0) then
begin
x1 := b / (2 * a);
Write('x1=', x1, 'x2=', x1);
end else
writeln('Корней нет');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
AnastasiaVolk534
13.01.2021 13:45
ТЕСТ НА ВРЕМЯ Имя сжатого файла: computer letter 7 1 2. Расширение графического файла: .PNG .ink .xlsx 7...
Ler4ic004
20.12.2019 18:53
Спрограммированием и циклом...
PrOFy100
20.12.2019 18:59
Найти сумму членов последовательности. писать на паскале...
Bohdanka999
20.12.2019 19:09
Объясните назначение диаграммы в электронных таблицах ...
Гулзат1111
20.12.2019 19:14
Необходимо подготовить логотип компании для печати в типографии (фирменные бланки). специализация компании — покупка золота. какую цветовую модель необходимо использовать? 1) rgb...
salta160680
20.12.2019 19:15
Как вывести элементы массива в обратном порядке? написать прогу для с++...
DAYH228
20.12.2019 19:22
надо написать то, что в таблице...
якек2
20.12.2019 19:24
Кот мурлыка придумал для кукарачи такую . ты находишься в клетке (5, 3). справа, начиная с клетки (5, 4), расположен плотный ряд кубиков с буквами с (серая) неизвестной длины....
makc59p0dpo2
20.12.2019 19:26
Муниципальный этап всош по информатике среди 7, 8 классов. 2019-2020 учебный год. , калининградская область, 14.12.2019 b. минимальное число имя входного файла: стандартный ввод...
Математика666
20.12.2019 17:34
Что такое графический редактор, и какие команды входят . !...
Популярные вопросы
Нужно ли многодетным семьям. если да то как...
2
11 . укажите верные утверждения: а) конечным пунктом торгового пути «из варяг...
3
Выделяется при сжигании 8г серы если теплота образования so2 из кислорода и...
1
Используя рисунок 3.6.2 и карту строения земной коры, объясните закономерности...
2
Раскройте скобку объясните орфограму. спички (не) трон в списках огонь...
1
Составьте вопросы к тексту 10 вопросов через 15 мин сдавать...
3
Какое количество теплоты выделится в нагревательном приборе при силе тока в...
1
Решите фастом контроль работа фастом...
1
Для получения 2.84г стеариновый кислоты потребуется стеарат натрия и раствор...
1
Как вы относитесь белякова произведения человек в футляре с презрением жалостью...
1
a, b, c, D: real;
x1, x2: real;
begin
Write('Введите А:'); Readln(a);
Write('Введите B:'); Readln(b);
Write('Введите C:'); Readln(c);
D := sqr(b) - (4 * a * c);
if (D > 0) then
begin
x1 := (-b + sqrt(D)) / (2 * a);
x2 := (-b - sqrt(D)) / (2 * a);
Writeln('x1=', x1);
Writeln('x2=', x2); end else
if(d = 0) then
begin
x1 := b / (2 * a);
Write('x1=', x1, 'x2=', x1);
end else
writeln('Корней нет');
end.