Напишите программу на языке паскаль.богатый и бедный заключили спор .богатый отдает каждый день 100 в течение месяца .бедный отдает в первый день копейку каждый следующий день в 2 раза больше в течение месяца ,кто выграет спор

ahgdy ahgdy    3   01.08.2019 22:30    2

Ответы
vika3475 vika3475  29.09.2020 11:58
Var m1,m2,st,i:integer;
begin
m1:=0; m2:=0;
st:=1;
for i:=1 to 30 do
 begin
 m1:=m1+100;
 m2:=m2+st;
 st:=st*2;
 end;
writeln('Богатый: ',m1,'  бедный: ',m2);
if m1<m2 
 then writeln('Выиграл богатый') else writeln('Выиграл бедный');
end.

Результат:
Богатый: 3000  бедный: 1073741823
Выиграл богатый
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика