Напишите программу на языке Pascal: нахождение максимального или минимального элемента в массиве из 10 чисел.

Mila672 Mila672    2   24.04.2020 06:09    1

Ответы
nastosetrova2 nastosetrova2  13.10.2020 19:31

Вариант, когда массив заполняется случайными числами:

var A: array [1..10] of integer;

var i,max,min: integer;

begin

max:=1;

min:=1;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random(100);

 write(A[i],' ');

 if (A[i]>A[max]) then max:=i;

 if (A[i]<A[min]) then min:=i;

 end;

writeln();

writeln('Минимальный элемент: ',A[min]);

writeln('максимальный элемент: ',A[max]);

end.

Вариант, когда массив вводится с клавиатуры:

var A: array [1..10] of integer;

var i,max,min: integer;

begin

max:=1;

min:=1;

for i:=1 to 10 do

 begin

 readln(A[i]);

 if (A[i]>A[max]) then max:=i;

 if (A[i]<A[min]) then min:=i;

 end;

writeln();

writeln('Минимальный элемент: ',A[min]);

writeln('максимальный элемент: ',A[max]);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика