Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если программа предложила большее число то пользователь нажимает < если программа предложила меньшее число то пользователь нажимает > а если угадала то = тема циклы

udinaaa udinaaa    3   17.05.2019 15:00    8

Ответы
вита4321 вита4321  10.06.2020 19:51

var min,max,n:integer;
c:string;
Begin
    min:=1;
    max:=1000;
    repeat
        n:=(max+min) div 2;
        writeln(n);
        read(c);
        case c of
            ">": min:=n+1;
            "<": max:=n-1;
        end
    until (c="=");
End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика