Напишите программу на языке C++, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные:
Три целых числа вводятся в одной строке через пробелы.

Выходные данные:
Программа должна вывести сумму, произведение и среднее арифметическое введенных чисел. Среднее арифметическое нужно вывести с точностью 3 знака после десятичной точки.

Примеры:
входные данные:
4 5 7
выходные данные:
4+5+7=16
4*5*7=140
(4+5+7)/3=5.333

aimuratsergei1234 aimuratsergei1234    1   19.10.2020 12:56    6

Ответы
liza0281 liza0281  18.11.2020 12:58

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int a, b ,c;

   cout<<"Введите 3 целых числа"<<endl;

   cin >>a>>b>>c;

   cout<<a<<"+"<<b<<"+"<<c<<"="<<a+b+c<<endl;

   cout<<a<<"*"<<b<<"*"<<c<<"="<<a*b*c<<endl;

   cout.precision(4);

   cout<<"("<<a<<"+"<<b<<"+"<<c<<")/3"<<"="<<(a+b+c)/3.<<endl;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика