Напишите программу на с++, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 9. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода,
не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: сумму всех чисел, кратных 3 и оканчивающихся на 9.

3aHo3a1538 3aHo3a1538    2   08.10.2019 20:40    5

Ответы
настя20034122003 настя20034122003  10.10.2020 05:13

#include <iostream>

using namespace std;

int main()

{

int a,S=0;

cin >> a;

while(a!=0)

{

if(a % 3 == 0 && a % 10 == 9) S=S+a;

cin >> a;

}

cout<<S;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика