Напишите программу на с#, которая будет менять в заданном в программе массиве целых чисел все элементы, которые равны указанному значению, на противоположное по знаку. реализовать программу следует с использованием функции, в которую изменяемое значение передаётся в качестве аргумента. например, все элементы массива, которые равны 2,будут меняться на -2.

SFDFGDDDDFGDGD SFDFGDDDDFGDGD    1   02.09.2019 22:00    5

Ответы
Nadiya75 Nadiya75  01.09.2020 06:57
Using System;

public class Test
{
public static int change(int x){return -x;}
public static void Main()
{
const int n=5;
int[,] a=new int[n,n];
Random rnd=new Random();
Console.Write("введите число:");
int c=int.Parse(Console.ReadLine());
Console.WriteLine("");
Console.WriteLine("исходный массив:");
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
a[i,j]=rnd.Next(1,10);
Console.Write(a[i,j]);
}
Console.WriteLine("");
}
Console.WriteLine("полученный массив:");
for(int i=0;i<n;i++)
{
for(int j=0;j<n;j++)
{
if(a[i,j]==c) a[i,j]=change(c);
Console.Write(a[i,j]);
}
Console.WriteLine("");
}
}
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика