Напишите программу на С Дана целочисленная прямоугольная матрица. Определить:
а) количество строк, не содержащих ни одного нулевого элемента;
б) максимальное из чисел, встречающихся в заданной матрице
более одного раза.
ещё нужно скрины работы программы

anastasia106444 anastasia106444    1   27.05.2020 20:01    3

Ответы
nikky228like nikky228like  15.10.2020 10:16

а)

#include <iostream>

#include <vector>

using namespace std;

bool is_any_nulls(vector<int> vec){

   for(int i: vec)

       if(i == 0)

           return true;

   return false;

}

signed main() {

   int n,m;

   cin >> n >> m;

   vector<vector<int>> a(n);

   for(int i = 0; i < n; i++){

       vector<int> temp(m);

       for(int &j: temp)

           cin >> j;

       a[i] = temp;

   }

   int cnt = 0;

   for(vector<int> i: a)

       if(!is_any_nulls(i))

           cnt++;

   cout << cnt;

}

б)

#include <iostream>

#include <vector>

#include <map>

using namespace std;

signed main() {

   int n, m;

   cin >> n >> m;

   map<int,int> mp;

   vector<vector<int>> a(n);

   for (int i = 0; i < n; i++) {

       vector<int> temp(m);

       for (int &j: temp){

           cin >> j;

           mp[j]++;

       }

       a[i] = temp;

   }

   int mx = -INT_MAX;

   for(auto i: mp)

       if(i.first > mx && i.second > 1)

           mx = i.first;

   cout << mx;    

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика