Напишите программу на с++ без динамических массивов с функцией Наименьшее общее кратное (НОК) двух натуральных чисел – это наименьшее число, которое делится нацело на оба исходных числа. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

Входные данные
Входная строка содержит два натуральных числа, разделённые пробелом – a и b .

Выходные данные
Программа должна вывести одно натуральное число: НОК заданных чисел.

the26 the26    3   11.04.2021 19:40    29

Ответы
konor271 konor271  11.04.2021 19:50

надеюсь правильно

Объяснение:

#include <iostream>

using namespace std;

int gcd(int a, int b) {

   return (a == 0) ? b: gcd(b % a, a);

}

 

int main() {

   int n, m = 0;

   cin >> n;

   for (int i = 0; i < n; i++) {

       int a;

       cin >> a;

       m = gcd(m, a);

   }

   cout << m;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
dedovdima14 dedovdima14  11.04.2021 19:50

1

2

3

4

5

6

7

8

9

10

11

var m,n,pr:word;

begin

read(m,n);

pr:=m*n;

while m<>n do

begin

if m>n then m:=m-n

else n:=n-m

end;

write(pr div m)

end

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика