Напишите программу на Python
Список квадратов
Дано число N. Выведите N квадратов чисел от 1 до N (включительно) в формате [1, 4, 9, 16,…, N**2]. Используйте функцию print() для вывода списка.

Входные данные:

В одной строчке дано натуральное число N≤200.

Выходные данные:

Список квадратов в указанном формате.

pinashinaanna27 pinashinaanna27    2   27.05.2020 11:09    16

Ответы
munisa333 munisa333  24.08.2020 22:04

N = int(input())

arr = [0] * N

for i in range(1,N + 1):

   arr[i - 1] = i ** 2

print(arr)

1 строка - ввод числа N

2 строка - создание массива на N элементов, заполненных нулями

3 строка - цикл на N шагов, где i будет изменяться от 1 до N включительно

4 строка - массивы нумеруются с 0, так что i - 1. Заполнение массива квадратами

5 строка - вывод. Если вывести массив такой командой, то он выведется в нужном формате

ПОКАЗАТЬ ОТВЕТЫ
polatovskiy2002 polatovskiy2002  24.08.2020 22:04

N = int(input())

print([i**2 for i in range(1, N+1)])

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика