Напишите программу на Python, которая в последовательности целых чисел находит два разных по значению наибольших числа среди чисел не кратных трем


Напишите программу на Python, которая в последовательности целых чисел находит два разных по значени

angeloknet1 angeloknet1    1   12.01.2022 10:56    2

Ответы
khairullina05 khairullina05  12.01.2022 11:00

Программа:

num = int(input("Введите число: "))

data_num = []

while num != 0:

   if num % 3 != 0:

       data_num += [num]

   num = int(input("Введите число: "))

num_max = max(data_num)

print("\nПервое максимальное число:", num_max)

data_num = [el for el in data_num if el != num_max]

print("Второе максимальное число:", max(data_num))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика