Напишите программу на Python'е для решения следующей задачи: Исполнитель НечетМ преобразует число на экране. У исполнителя НечетМ две команды, которым присвоены номера:

1. прибавь 1

2. сделай нечётное

Первая из этих команд увеличивает число x на экране на 1, вторая переводит число x в число 2x+1. Например, вторая команда переводит число 10 в число 21. Программа для исполнителя НечетМ – это последовательность команд. Сколько существует таких программ, которые число 1 преобразуют в число 27, причём траектория вычислений не содержит число 26? Траектория вычислений программы – это последовательность результатов выполнения всех команд программы. Например, для программы 121 при исходном числе 7 траектория будет состоять из чисел 8, 17, 18.

valnov24200105oxnmv8 valnov24200105oxnmv8    3   20.03.2021 19:13    4

Ответы
дывавып дывавып  20.03.2021 19:20

a = 1

res = 0

def pr(x, mas):

   if x == 27:

       global res

       res+=1

   elif x<27:

       if x+1 !=26:

           pr(x+1, mas+[x+1])

       if 2*x+1 != 26:

           pr(2*x+1, mas+[2*x+1])

pr(1, [1])

print(res)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика