Напишите программу на питоне. Текстовый файл содержит только заглавные буквы латинского алфавита (ABC…Z). Определите символ, который чаще всего встречается в файле после двух одинаковых символов.

Например, в тексте CCCBBABAABCC есть комбинации CCC, CCB, BBA и AAB. Чаще всего — 2 раза — после двух одинаковых символов стоит B, в ответе для этого случая надо написать B.

Для выполнения этого задания следует написать программу. Ниже приведён файл, который необходимо обработать с данного алгоритма.

YumiChan153 YumiChan153    2   29.03.2021 17:45    27

Ответы
enotick3010 enotick3010  28.04.2021 17:50

f = open('24.txt', 'r')

s = f.read()

d = dict()

for i in range(1, len(s) - 1):

   if s[i-1] == s[i-2]:

       if s[i] not in d:

           d[s[i]] = 1

       else:

           d[s[i]] += 1

print(max(d, key=lambda k: d[k]))

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика