Напишите программу на питоне. Написать программу позволяющую обрабатывать строку посещаемости.
Пользователь вводит строку в виде <нн+н+++н+нн++н>, где <н> это пропуск, а <+> это посещения.
Программа должна вывести в качестве ответа следующую информацию:
Количество занятий N
Количество пропусков M
Пропущено X%. (Процент)

маргарита209 маргарита209    2   14.04.2021 12:30    8

Ответы
Filomena0w0 Filomena0w0  14.05.2021 12:30

N = 0

M = 0

a = input()

for i in range(len(a)):

   if a[i].lower() == 'н':

       M += 1

       N += 1

   elif a[i] == '+':

       N += 1

X = round(100 * M / N, 2)

print(f'Количество занятий: {N}',

     f'Количество пропусков: {M}', f'Пропущено {X}%', sep='\n')


Напишите программу на питоне. Написать программу позволяющую обрабатывать строку посещаемости. Польз
Напишите программу на питоне. Написать программу позволяющую обрабатывать строку посещаемости. Польз
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика