Напишите программу на питоне Делители факториала
По заданному натуральному числу N необходимо вычислить количество натуральных чисел, которые являются делителями N! (факториала числа N).
Например, при N=4, N!=4⋅3⋅2⋅1=24. Это число имеет следующие делители: 1,2,3,4,6,8,12,24. Таким образом, искомое количество составляет 8.
Напишите программу, которая по натуральному N находит количество делителей его факториала.
Формат входных данных
Единственная строка входного файла содержит одно целое число N(1≤N≤45).
Формат выходных данных
Единственная строка выходного файла должна содержать одно целое число — найденное количество делителей числа N!
Примеры
Ввод
4
Вывод
8

andrei271 andrei271    3   14.06.2020 23:18    16

Ответы
Horoshist2287 Horoshist2287  15.10.2020 14:00

Код + скриншот (код и вывод компилятора). Строки с #... - комментарии. Если хотите, что бы показывался весь процесс работы программы - уберите только "#". Если не нужно - можете удалить строки с #... (не обязательно):

N = int(input("N = "))

fact_N = 1

for i in range(1,N+1):

   fact_N *= i

#print("Factorial N = ",fact_N)

count_dividers = 0

for divider in range(1,fact_N+1):

   if (fact_N % divider == 0):

       count_dividers += 1

#        print(count_dividers,"divider = ",divider)

print("Amount of dividers for '",N,"' - ",count_dividers)


Напишите программу на питоне Делители факториала По заданному натуральному числу N необходимо вычисл
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика