Напишите программу(на Паскале) вычисления суммы всех положительных элементов массива, которые вводятся с клавиатуры

НикаЛисовская НикаЛисовская    2   08.12.2020 05:43    2

Ответы
Аида1611 Аида1611  07.01.2021 05:56

var i, sum, num : integer;

var D: array [0..10] of integer;

begin

 sum := 0;

 

 for i:= 0 to 10 do begin

   readln(num);

   D[i] := num;

 end;

 

 for i := 0 to 10 do begin

   if D[i] >= 0 then

     sum := sum + D[i];

 end;

 

 writeln('Результат = ' + sum);  

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика