Напишите программу НА ПАСКАЛЕ, которая выводит последнее слово переданной её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки. Входные данные
Входная строка содержит произвольную последовательность символов.

Выходные данные
Программа должна вывести последнее слово этой строки.

Примеры
входные данные
Abra babra cadabra
выходные данные
cadabra

888DeLtApLaN888 888DeLtApLaN888    3   08.03.2021 20:04    1

Ответы
ХудшийИзХудших ХудшийИзХудших  07.04.2021 20:05

Program z1;  Var i,b,j,n:integer; s,space,h:string;      a: array [1..1000] of string;Begin  write('Введите текст - ');  readln(s);  b:=length(s);  space:=' ';  i:=1;  n:=0;  j:=1;  while i<=b do  begin    h:='';    while s[i]<>space do    begin      h:=h+s[i];      i:=i+1;    end;    a[j]:=h;    j:=j+1;    i:=i+1;    n:=n+1;  end;      write(a[n],' ');  End. Только в конце предложения ставь тоже пробел!

Объяснение:

Сори писал с телефона

ПОКАЗАТЬ ОТВЕТЫ
WoudBack1 WoudBack1  07.04.2021 20:05

Объяснение:

Var

s,s2:string;

i:byte;

begin

readln(s);

for i:=length(s) downto 1 do

if s[i] in [' ','.',','] then delete(s,i,1)

else break;

s2:='';

for i:=length(s) downto 1 do

if not(s[i] in [' ','.',',']) then s2:=s[i]+s2

else break;

writeln(s2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика